Answered By: Lippincott Library
Last Updated: Jun 30, 2015     Views: 354

Thomson ONE will only work using Internet Explorer (IE), and it has some issues displaying with full functionality even within certain versions of that browser -- including IE10, which is most commonly loaded on workstations within the Libraries and Huntsman Hall.

To sidestep these problems, use the steps described in our blog post, "Thomson One and Browser Compatibility: The Case of IE10".